Escolha uma Página

Saiu ontem a atualização para o WordPress 2.8. Porém essa versão parece que está dando dôr de cabeça pra um monte de blogueiros (inclusive eu). Depois de dançar o miudinho por algumas horas, consegui atualizar meu blog para o 2.8 e vou passar algumas dicas para que seu upgrade seja o mais tranquilo possível :)

Faça Backup de Tudo Antes!

Bom, antes de fazer qualquer coisa, faça um backup de tudo o que você tem ai. Base de dados, posts, temas, uploads… Enfim tudo.

O que recomendo é duplicar a pasta onde está instalado o seu blog e renomear ele para “blog-velho” por exemplo. Isso vai te salvar de vários apuros.

Atualização Automática

O que estava funcionando muito bem nas versões anteriores, nessa aqui está dando uma canseira: Atualização Automática. Eu fiz o upgrade me utilizando desse recurso, mas ele quebrou todo o blog. Pelas pesquisas que fiz, isso ocorre por causa de incompatibilidade de uma série de plugins. De qualquer forma, fuja da atualização automática e faça o upgrade manualmente.

Fazendo o Upgrade do WordPress de Forma Segura

Faz um bom tempo, eu escrevi um artigo a respeito de como se fazer um upgrade de forma segura no WordPress. Recomendo que dêem uma olhada, ele continua me salvando muito tempo.

Corrigindo os Problemas de Codificação de Caracteres

Após a instalação vi que a codificação UTF-8 não estava configurada corretamente. Isso acaba gerando textos com caracteres estranhos. Para corrigir abra o arquivo wp-config.php e mude a linha 31 que tem o seguinte conteúdo:

define(‘DB_CHARSET’, ‘utf8’);

para:

define(‘DB_CHARSET’, ‘utf-8’);

E o problema é corrigido :) Esse problema só ocorre se você fizer uma instalação limpa ou utilizar o arquivo wp-config-sample.php que vem com essa versão do WordPress.

E quem é o culpado afinal?

É dificil de crer que essa versão do WordPress tenha vindo com tantos bugs e problemas. Mas a final quem é o culpado dessa versão estar tão instavel? Acredito que não seja culpa do pessoal que trabalhou no WordPress, (tirando a falha do UTF-8, mau Sapão… mau Sapão) mas sim dos desenvolvedores de plugins, que não atualizaram seus produtos para suportar o 2.8. Agora estou rodando o WordPress com uma instalação bem espartana, somente com o plugin nextGEN que, aparentemente, foi um dos poucos que foram testados nesse release.

E você, teve algum problema pra instalar essa versão do WP?  Deixe um comentário.